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Overview 

This package fully reproduces all outputs in the report “Infrastructure Foundations - From 
Current Assets to Future Growth”. It consists of this README file, [structure of the files to 
be shared] 

To replicate the whole report, only the user path in the main code files need to be adjusted.  

Data Availability 

This section will outline where and how the data supporting the findings of the study can 
be accessed and used. This is crucial, especially for replicating the results, as only the same 
data will be able to produce consistent results. Please note:  

Some data cannot be made publicly available. 

 

Data Sources 

 

Raw Data File Name 
(under path: “Report_ReproduciblePackage\Data\Raw\”) 
Energy_StockValue_national.csv 
Energy_StockValue_admin0.csv 
Energy_StockValue_admin1.csv 
Energy_StockValue_admin2.csv 

Source: Development Data Hub  
URL: 
https://datacatalog.worldbank.org/int/data/

https://datacatalog.worldbank.org/int/data/dataset/0067069/energy_infrastructure_stock_and_value


 

 dataset/0067069/energy_infrastructure_stoc
k_and_value  
Availability: Official Use Only 

Combined_PowerPlantsDataset_Share.csv 
Energy_PowerPlants_Stock_Capital_admin2.csv 

Source (Access year): Compiled by the 
project team from public and proprietary data 
providers including Global Power Plant 
Database (Version: 1.3.0, Release Year: 2021-
06-02 ); Global Integrated Power Tracker 
February 2025 (February 2025 update); 
World Bank EPM model (May, 2025) 
Availability: Please contact the data provider 
from the below DDH url for the sharing of the 
data: 
https://datacatalog.worldbank.org/int/data/
dataset/0067069/energy_infrastructure_stoc
k_and_value. 

ImpliedE_Final.csv Source: Compiled by the project team, main 
data comes from the meta-analysis paper 
(Foster 2025) and World Bank / ESMAP 
Energy Planning Model (EPM).  
URL: https://www.esmap.org 
https://documents.worldbank.org 
Access year: 2026 
Availability: Included in the reproducible 
package as a local project dataset. 

Railway_StockValue_national.csv 
Railway_StockValue_admin1.csv 
Railway_StockValue_admin2.csv 
 
results_v4.csv 
 
 
 

Source: Development Data Hub  
URL: 
https://datacatalog.worldbank.org/int/data/
dataset/0067070/transport_infrastructure_st
ock_and_value   
Availability: Official Use Only 

population_total.csv Source: World Bank Open Data, Population, 
total (Indicator: SP.POP.TOTL), World 
Development Indicators 
URL: 
https://data.worldbank.org/indicator/SP.PO
P.TOTL 
Access year: 2025 
Availability: Publicly available 

1112_WEO_CAPEX.csv Source: International Energy Agency (IEA), 
World Energy Outlook (WEO) techno-
economic / capital cost assumptions for 
power-generation technologies. 

https://datacatalog.worldbank.org/int/data/dataset/0067069/energy_infrastructure_stock_and_value
https://datacatalog.worldbank.org/int/data/dataset/0067069/energy_infrastructure_stock_and_value
https://datacatalog.worldbank.org/int/data/dataset/0067069/energy_infrastructure_stock_and_value
https://datacatalog.worldbank.org/int/data/dataset/0067069/energy_infrastructure_stock_and_value
https://datacatalog.worldbank.org/int/data/dataset/0067069/energy_infrastructure_stock_and_value
https://www.worldbank.org/en/programs/power-system-decarbonization-pathways/methodology
https://www.worldbank.org/en/programs/power-system-decarbonization-pathways/methodology


 

URL: https://www.iea.org/reports/world-
energy-outlook-2025 
https://www.iea.org/reports/global-energy-
and-climate-model/techno-economic-inputs 
Access year: 2025 
Availability: Publicly available 

1112_IRENA_Total_Installed_Cost.xlsx Source: International Renewable Energy 
Agency (IRENA), Renewable Power 
Generation Costs database/report series 
URL: 
https://www.irena.org/Publications/2024/S
ep/Renewable-Power-Generation-Costs-in-
2023 
https://www.irena.org/reports/global-
energy-and-climate-model/techno-economic-
inputs 
Access year: 2025 
Availability: Publicly available 

1112_CPI_Table 3.1.xlsx Source: Compiled from World Bank / ESMAP 
transmission cost assumptions and related 
power-system planning references. 
URL: https://www.esmap.org 
https://documents.worldbank.org 
Access year: 2026 
Availability: Publicly available, locally 
compiled for project use. 

mradata.dta Source: Foster, V., Gorgulu, N., Jain, D., Straub, 

S., & Vagliasindi, M. (2025). The impact of 

infrastructure on development outcomes: A 

meta-analysis. World Bank Research 

Observer. 

URL: 

https://documents1.worldbank.org/curated/

en/099510203092318515/pdf/IDU08a9d8af

40f7d50487e0837208744c048b215.pdf 

Access year: 2025 
Availability: Shared by authors. The author 
may be contacted at vfoster@worldbank.org, 
mvagliasindi@worldbank.org, 
ngorgulu@worldbank.org, 
stephane.straub@tse-fr.eu, and 
jain.dhruv@tse-fr.eu. 

population_ecu_admin2.xlsx Source: Ecuador Instituto Nacional de 
Estadisticas y Censos (National Institute of 
Statistics and Census) 



 

URL: 
https://www.ecuadorencifras.gob.ec/censos/ 
Access year: 2025 
Availability: Publicly available  

Additional data in folder .. \04_AdditionalRestrictedData: 
digital_total_stock_february_23.csv 
digital_total_stock_february_23_time_series_pan
el.csv 
 
submarine_clean_data.csv 
ixp_costs.xlsx 
fibercables_costsestimates.csv 
CT_dealvalues_towerxchange 1.csv 
full_dataset_with_explanatory.csv 
train.csv 
subcables_cost.xlsx 
 
datacenters_final_2026.xlsx 
ecuador_sites_macro_micro_costed_depr_2025.c
sv 
 
 
admin2_ecuador_total.csv  
 
 

Source: Multiple sources using data from 
proprietary data. Telegeography 
(https://www2.telegeography.com/ 
); GlobalData 
(https://www.globaldata.com/); and publicly 
available data from TowerXchange 
(https://infraxchange.com/); PCH 
(https://www.pch.net/ixp/); and 
OpenCellId 
(https://www.opencellid.org/downloads.php
) 
Access year: 2025 
Availability: Raw and cleaned data for the 
digital sector is compiled by the project team 
from public and proprietary data. 
Confidential. If needed, please contact 
Estefania Belen Vergara Cobos 
(evergaracobos@worldbank.org) for 
application details.  
 

itu_transmission_lines.geojson 
itu_transmission_lines_validated.geojson 
 

Source: https://bbmaps.itu.int/bbmaps/  
Access date: February 15, 2025 
Availability: The file 
itu_transmission_lines_validated.geojson is a 
validated version of the ITU transmission 
lines data used for Map 2.3. It was derived 
from the ITU Broadband Maps, BBmaps, 
transmission network layer and subsequently 
validated for use in the map. If needed, please 
contact Estefania Belen Vergara Cobos 
(evergaracobos@worldbank.org) for 
application details.  
 

Ookla_data_countrylevel.dta Source: 
https://registry.opendata.aws/speedtest-
global-performance/ 
Access date: February 15, 2025 
Availability: Raw ookla data. Speedtest by 
Ookla Global Fixed and Mobile Network 
Performance Maps, Open Dataset. If needed, 

https://www.globaldata.com/
https://infraxchange.com/
https://www.pch.net/ixp/
mailto:evergaracobos@worldbank.org
https://bbmaps.itu.int/bbmaps/
mailto:evergaracobos@worldbank.org
https://registry.opendata.aws/speedtest-global-performance/?utm_source=chatgpt.com
https://registry.opendata.aws/speedtest-global-performance/?utm_source=chatgpt.com


 

please contact Estefania Belen Vergara Cobos 
(evergaracobos@worldbank.org) for 
application details.  
License: CC BY NC SA 4.0. 
 
 

Additional data in folder ..\00_Non Sectoral Data\Raw: 
\Map\.. Source: World Bank Official Boundaries (two 

versions - Jun 17, 2025 Version 5; Mar 18, 
2020) 
URL: 
https://datacatalog.worldbank.org/int/searc
h/dataset/0038272/world-bank-official-
boundaries 
Access year: May & Aug 2025 
Availability: Publicly Available 

\IMFInvestmentStock\IMFInvestmentandCapit
alStockDataset2021.xlsx 

Source: IMF Investment and Capital Stock 
Dataset, 1960-2019 (Version May, 2021) 
URL: 
https://infrastructuregovern.imf.org/content
/dam/PIMA/Knowledge-
Hub/dataset/IMFInvestmentandCapitalStock
Dataset2021.xlsx 
Access year: 2025 
Availability: Publicly Available 
Comments: Additional calculations to back 
out the depreciation rate for road, railway, 
and transmission and distribution lines are 
added in sheet2 and sheet 3. Further details 
about the methodology are included in the 
report.  

\CountryData\GDPContributor.xlsx Source: World Development Indicators 
URL: 
http://databank.worldbank.org/data/home.a
spx 
Access year: 10/07/2025 
Availability: Publicly available 

\CountryData\PWT_2025-12-01T21-
30_export.csv 

Source: Penn World Table (PWT) 
URL: 
https://www.rug.nl/ggdc/productivity/pwt/ 
Access year: 12/1/2025 
Availability: Publicly available 

\CountryData\CLASS.xlsx 
\CountryData\ historicincomegroups.csv 
\CountryData\ classy.csv 

Source: World Bank, World Bank Country and 
Lending Groups 

mailto:evergaracobos@worldbank.org
https://datacatalog.worldbank.org/int/search/dataset/0038272/world-bank-official-boundaries
https://datacatalog.worldbank.org/int/search/dataset/0038272/world-bank-official-boundaries
https://datacatalog.worldbank.org/int/search/dataset/0038272/world-bank-official-boundaries


 

URL: 
https://datahelpdesk.worldbank.org/knowle
dgebase/articles/906519-world-bank-
country-and-lending-groups 
Access year: 2025 
Availability: Publicly available 

\CountryData\DoingBusiness_Data.csv Source: World Bank, Doing Business Database 

URL: 
https://archive.doingbusiness.org/en/doingb
usiness 
Access year: 2024 
Availability: Publicly available 

\CountryData\Enterprise_Data.csv Source: World Bank, Enterprise Surveys 

URL: https://www.enterprisesurveys.org/ 

Access year: 2024 

Availability: Publicly available 

\CountryData\Governance_Data.csv Source: World Bank, Worldwide Governance 

Indicators (WGI) 

URL: 

https://databank.worldbank.org/source/wor

ldwide-governance-indicators 

Access year: 2024 

Availability: Publicly available 

\CountryData\WDI_Data.csv Source: World Bank, World Development 

Indicators (WDI) 

URL:  
https://databank.worldbank.org/source/wor
ld-development-indicators  
Access year: 2025 

Availability: Publicly available 

\CountryData\WDI_Data_20260113.csv Source: World Bank, World Development 

Indicators (WDI) 

URL:  
https://databank.worldbank.org/source/wor
ld-development-indicators  
Access year: 2026 
Availability: Publicly available 

\CountryData\ILO_Data.xlsx 

 

Source: International Labour Organization 

(ILO), ILOSTAT Database 

URL:  https://ilostat.ilo.org/data/ 

Access year: 2026 

Availability: Publicly available 



 

\CountryData\d8a58af6-11b5-47d0-aa47-

d469c1a87c1a_Data.csv 

Source: World Bank, Urban population (% of 

total population) 

URL:  

https://data.worldbank.org/indicator/SP.UR

B.TOTL.IN.ZS 

Access year: 2025 

Availability: Publicly available 

\CountryData\e8392a03-3c8e-4120-9f05-

b1a53380ad09_Data.csv 

Source: World Bank, International 

Comparison Program (ICP) 

URL:  

https://www.worldbank.org/en/programs/ic

p  

Access year: 2025 

Availability: Publicly available 

\CountryData\construction_BOS_data.xlsx Source: World Economic Forum, Global 

Competitiveness Report / Global 

Competitiveness Index dataset 

URL:  

https://www3.weforum.org/docs/WEF_TheG

lobalCompetitivenessReport2019.pdf? 

Access year: 2025 

Availability: Publicly available 

\CountryData\labor cost final.xlsx Source: Global Labor Database data and 

ILOSTAT data 

URL:   https://ilostat.ilo.org/topics/labour-

costs/; 

https://worldbank.github.io/gld/Support/A

%20-

%20Guides%20and%20Documentation/GLD

%20Manual%20Files/Introduction%20to%2

0the%20GLD.html  

Access year: 2025 

Availability: Publicly available 

Comment: Collected, cleaned, and 

harmonized by staff and consultants.  

\CountryData\population_total.csv Source: World Bank Open Data, Population, 
total (Indicator: SP.POP.TOTL), World 
Development Indicators 
URL: 
https://data.worldbank.org/indicator/SP.PO
P.TOTL 
Access year: 2025 

https://www.worldbank.org/en/programs/icp
https://www.worldbank.org/en/programs/icp
https://ilostat.ilo.org/topics/labour-costs/
https://ilostat.ilo.org/topics/labour-costs/
https://worldbank.github.io/gld/Support/A%20-%20Guides%20and%20Documentation/GLD%20Manual%20Files/Introduction%20to%20the%20GLD.html
https://worldbank.github.io/gld/Support/A%20-%20Guides%20and%20Documentation/GLD%20Manual%20Files/Introduction%20to%20the%20GLD.html
https://worldbank.github.io/gld/Support/A%20-%20Guides%20and%20Documentation/GLD%20Manual%20Files/Introduction%20to%20the%20GLD.html
https://worldbank.github.io/gld/Support/A%20-%20Guides%20and%20Documentation/GLD%20Manual%20Files/Introduction%20to%20the%20GLD.html
https://worldbank.github.io/gld/Support/A%20-%20Guides%20and%20Documentation/GLD%20Manual%20Files/Introduction%20to%20the%20GLD.html


 

Availability: Publicly available 

\CountryData\ICRG_EconCountryData.csv 

\CountryData\ICRG_PRS.csv 

\CountryData\ICRG_RiskData.csv 

Source: International Country Risk Guide 
URL: www.prsgroup.com 
Access year: 2025 
Availability: Publicly available 

\CountryData\LAC_4HRL_ECO_CUR_NB_A-

20241217T1929.dta 

\CountryData\EAR_4HRL_SEX_OCU_CUR_NB_A-

20241217T1932.dta 

 

Source: International Labour Organization 
URL: https://ilostat.ilo.org/data/ 
Access year: 2024 
Availability: Publicly available 

\ Meta-Analysis Estimates \Cost of Capital.xlsx Source: Professor Aswath Damodaran – NYU 

Stern School of Business 

URL:  

https://pages.stern.nyu.edu/~adamodar/Ne

w_Home_Page/datafile/ctryprem.html 

Access year: 2026 

Availability: Publicly available 

\ Meta-Analysis Estimates\ 

ElasticityINF_INFFlagship_20250811.xlsx 

Source: Foster, V., Gorgulu, N., Jain, D., Straub, 

S., & Vagliasindi, M. (2025). The impact of 

infrastructure on development outcomes: A 

meta-analysis. World Bank Research 

Observer. 

URL: 

https://documents1.worldbank.org/curated/

en/099510203092318515/pdf/IDU08a9d8af

40f7d50487e0837208744c048b215.pdf 

Access year: 2025 

Availability: Shared by authors. The author 

may be contacted at vfoster@worldbank.org, 

mvagliasindi@worldbank.org, 

ngorgulu@worldbank.org, 

stephane.straub@tse-fr.eu, and 

jain.dhruv@tse-fr.eu. 
\Meta-Analysis Estimates\Cost of Capital.xlsx Source: Professor Aswath Damodaran – NYU 

Stern School of Business 

URL:  

https://pages.stern.nyu.edu/~adamodar/Ne

w_Home_Page/datafile/ctryprem.html 

Access year: 2026 

Availability: Publicly available 

Raw Data for Selected Figures (under path: “Report_ReproduciblePackage\Data\ FigureData\”) 



 

Figure 3.S1 The Roads of Hispaniola\.. 
Figure 4.8 Subnational Distribution of Line 
Transport Infrastructure\.. 
Figure 6.7 Subnational Distribution of Transport 
Nigeria\.. 
Figure 6.8 Subnational Distribution of Roads\.. 

Source: OpenStreetMap (use geofabric); 
WorldPop; Development Data Hub  
URL: , https://download.geofabrik.de; 
https://data.worldpop.org/GIS/Population; 
https://datacatalog.worldbank.org/int/data/
dataset/0067070/transport_infrastructure_st
ock_and_value   
Access year: 2025 

Availability: Publicly available 

Figure 5.8 Modelling Results Unit Cost of 
Roads\.. 
Figure 5.9 Modelling Results Unit Cost of 
Railways\.. 

Source: results calculated from GlobalData 

URL:  https://www.globaldata.com/ 

Access year: 2025 

Availability: Data is proprietary, the results 

are publicly available 

  

  

  

 

Instructions for Replicators 

New users should follow these steps to run the package successfully: - Users must first have 
access to all data files if they are not included in the reproducibility package. They should 
go to the mentioned links, download the listed files, and place them in the data folder. - 
Update the following files with your directory paths 

 

Output Steps to Follow 
00_IndependentVar.csv 
00b_IndependentVar.csv 

First, need to run this code as it generates 
information used for other sectoral data 
00_IndependentVar_MasterDoFile.do 
00b_IndependentVar_MasterDoFile.do 
 

prelim_capital_elas.xlsx 
prelim_capital_elas_meta.xlsx 

Run 2 separate files, to generate another part that 
will be used to create the main dataset for the 
report:  
11_CapitalCost_Elasticity_GDP_Compile.do 
12_Data_construction_elasticity_revised.R 

https://download.geofabrik.de/
https://data.worldpop.org/GIS/Population
https://www.globaldata.com/


 

 Run the code to produce the final cleaned dataset: 
20_CompileDataset.ipynb 

Exhibit Outputs Run the followings files: 
31_Python_Chap 1~6.ipynb 
32_STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do 
33_R_Chap 2,5.R 
34_DigitalFigures.R 
35_figure6.12_code.R 
36_Chapter7Appendix2_EnergyMeta.ipynb 

 

 

 

List of Exhibits 

The provided code reproduces: 

• ☐ All numbers provided in text in the paper 

• ☐ Selected tables and figures in the paper, as explained and justified below 

 

Note: when the map team recreated the global map, the median value changes due to the 
selection of economies shown. Some visual differences are expected due to the territorial 
choice. The recreated map uses the same output data.  

 

Ex
hi
bit 
na
m
e 

Output filename Script Not
e 

Fig
ur
e 
ES.
1 

Same as Figure 2.1 STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do 

(Line 333) 

Twi
n 

Ma
p 
ES.
1 

Same as Chapter4_Figure5_BRA.png Same as Figure 4.5a Twi
n 

Ma
p 
ES.
2 

Same as Chapter4_Figure5_NGA.png Same as Figure 4.5b Twi
n 

Commented [XL1]: @Seojin Kim  

mailto:skim47@worldbank.org


 

Ma
p 
ES.
3 

“ES4_required_data.csv” 

Original map: 
ChapterES_Figure4_Transport_per_capita.png 

Recreated map uses the csv output file.  

 

 

 

Python_Chap 1~6.ipynb Ma
p 
tea
m 
rec
reat
ed 

Fig
ur
e 
ES.
2 

Same as Figure 2.10 STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do  

(Line 283) 

Twi
n 

Fig
ur
e 
ES.
3 

Same as Figure 2.12 STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 234) Twi
n 

Fig
ur
e 
ES.
4 

Same as Figure 3.3 STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 723) Twi
n 

Fig
ur
e 
ES.
5 

Same as Figure 3.4 STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 814) Twi
n 

Fig
ur
e 
ES.
6 

Same as Chapter3_Figure5a.png Chapter7Appendix2_EnergyMeta.ipynb Twi
n 

Fig
ur
e 
1.1 

Figure 1.1 Distribution of estimated elasticities 
from the literature.png 

Python_Chap 1~6.ipynb  

Ta
ble 
1.1 

Shared by operational team, not reproducible, using bank’s internal data 

Ta
ble 
1A.
1 

 01_CompileDataset.ipynb Su
mm
ary 
stat
s 
for 
the 
clea
ned 
dat
aset 

Fig
ur
e 
2.1 

Figure 2.1.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 333) Sa
me 
as 
Fig
ure 



 

ES.
1 

Fig
ur
e 
2.2 

Chapter2_Figure2_Distribution_of_power_generati
on_capacity.png 

R_Chap 2,5.R  

Ma
p 
2.1 

“Figure 2.3.csv” 

Original map: Figure 2.3.png 

Recreated map uses the csv output file. 

Python_Chap 1~6.ipynb Ma
p 
tea
m 
rec
reat
ed 

Ma
p 
2.2
a 

“Figure2_4a.csv” 

Original map: Figure2_4a_Roads_per_capita.png 

Recreated map uses the csv output file. 

Python_Chap 1~6.ipynb Ma
p 
tea
m 
rec
reat
ed 

Fig
ur
e 
2.2
b 

Figure2_4b_Rail_per_capita Python_Chap 1~6.ipynb Ma
p 
tea
m 
rec
reat
ed 

Fig
ur
e 
2.3 

Raw data illustration, proprietary data  

Data and code shared in NDA\Digital\ Figure2_3.zip. 

Data Source: Multiple sources using data from proprietary data. Telegeography 
(https://www2.telegeography.com/ 

); GlobalData (https://www.globaldata.com/); and publicly available data from TowerXchange 
(https://infraxchange.com/) and OpenCellId (https://www.opencellid.org/downloads.php) 

Access year: 2025 

Availability: Raw and cleaned data for the digital sector is compiled by the project team from public and 
proprietary data. Confidential. If needed, please contact Estefania Belen Vergara Cobos 
(evergaracobos@worldbank.org) for application details.  

 

 

Ma
p 
2.3 
a & 
b 

Raw data illustration, proprietary data  

Data shared in NDA\Digital\ Map 2_3 

Data Source: Multiple sources using data from proprietary data. Telegeography 
(https://www2.telegeography.com/ 

); GlobalData (https://www.globaldata.com/); and publicly available data from TowerXchange 
(https://infraxchange.com/) and OpenCellId (https://www.opencellid.org/downloads.php) 

Access year: 2025 

Availability: Raw and cleaned data for the digital sector is compiled by the project team from public and 
proprietary data. Confidential. If needed, please contact Estefania Belen Vergara Cobos 
(evergaracobos@worldbank.org) for application details.  

 

Raw data illustration, proprietary data  

Data shared in NDA\Digital\Map 2.3 Digital Infrastructure Expansion in Asia 

Map 2.3a & b — Raw data illustration, proprietary data. Data shared under NDA in NDA\Digital\Map 2.3 Digital 
Infrastructure Expansion in Asia. 

The map was produced in QGIS using the following layers: 

https://infraxchange.com/
mailto:evergaracobos@worldbank.org
https://infraxchange.com/
mailto:evergaracobos@worldbank.org


 

Point layers (CSV, imported via Layer → Add Layer → Add Delimited Text Layer): 

 

Internet Exchange Points (IXPs): ixp/ITU_ixp.geojson 

Data Centers: data_center/(GD,%20TG)%20data_center_merged.csv 

Cell towers (Asia): CellTowers/distribution_with_coordinates/cell_towers_asia.csv 

Cell towers (China): cell_towers_china.csv 

Cell towers (Japan): cell_towers_japan.csv 

Cell towers (LAC–Caribbean): cell_towers_lac_caribbean.csv 

Cell towers (LAC–inland): cell_towers_lac_inland.csv 

 

Cable layers (shapefiles/GeoJSON, imported via Layer → Add Layer → Add Vector Layer): 

 

Submarine cables (global, filtered rfs_year <= 2015): TeleGeography, 
submarine_cable/Submarine_cables.geojson 

Submarine cables (China): China/submarine_cables_china.gpkg 

Submarine cables (Japan): China/submarine_cables_japan.gpkg 

Terrestrial/fiber optic cables: ITU, terrestrial_cable/itu_transmission_lines.geojson 

Fiber optic cables (China): China/fiber_optic_cables_china.gpkg 

 

Boundary layers: 

 

World map (countries): QGIS built-in (world_map.gpkg) 

China boundary: China/cn.gpkg 

Japan boundary: Japan/gm-jpn-bnd_u_2_1/polbnda_jpn.shp 

Philippines boundary: PSA NAMRIA, phl_adm_psa_namria_20231106.shp 

 

All CSV layers were clipped to country boundaries via Vector → Clip. The OSM Standard basemap was added 

using Plugins → QuickMapServices → OSM Standard. The cable data were sourced from shapefiles. Submarine 
cable shapefiles were obtained from TeleGeography, and terrestrial cable shapefiles from the ITU.  

 

Fig
ur
e 
2.4 

Figure 2.7.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 525)  

Fig
ur
e 
2.5 

Figure 2.8.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 557)  

Fig
ur
e 
2.6 

Figure 2.9.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 593)  

Fig
ur
e 
B2.
1.1 

Figure 2.b1.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 2228)  

Fig
ur
e 
2.7 

Figure 2.10.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 283) Sa
me 
as 
Fig
ure 
ES.
5 



 

Fig
ur
e 
2.8 

Figure 2.11.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 56)  
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Figure 2.12.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 234) Sa
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Figure 2.A1.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 90)  
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Figure 2.A2.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 136)  
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Figure 3.1.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do  
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Figure 3.2.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 637)  
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Figure 3.b1.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 680)  
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Figure 3.3.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 723) Sa
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Figure 3.4.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 814) Sa
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Table 3.1.xlsx STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 994)  
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Table 3.b1.xlsx STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 1559)  



 

Fig
ur
e 
B3.
2.1 

Figure 3.b2.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 1375)  
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Table 3.2.xlsx STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 1077)  
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Chapter3_Figure5a.png Python_Chap 1~6.ipynb Sa
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Fig
ure 
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Chapter3_Figure5b.png Python_Chap 1~6.ipynb  
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Figure 3.6.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 862)  
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Figure 3.7.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 905)  
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Table 3.4.xlsx STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 1028)  
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Table 3.A1.xlsx STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 957)  
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Figure 3.A1.png STATA_Chap 2,3,ES, Table 3.1 ~ 3b1.do (Line 1180)  
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Data and shapefiles provided in Data \FigureData\ 
Figure 3.S1 The Roads of Hispaniola\Materials\ 
Shapefiles 

Road network data from OpenStreetMap (haiti-
and-domrep-250701.osm.pbf) were downloaded 
from GeoFabrik, 
https://download.geofabrik.de/central-
america/haiti-and-domrep.html#, downloading 
directly from the link for Haiti and Dominican 
Republic for July 1, 2025, converted to a shapefile 
and visualized in QGIS. 
Administrative boundaries shapefile was obtained 
from the World Bank Cartography unit 
(https://datacatalog.worldbank.org/int/search/da
taset/0038272/world-bank-official-boundaries) 
Population data were downloaded from WorldPop, 
https://data.worldpop.org/GIS/Population/Global

Map S3.1.1a, b & c — Original map for this 
publication. Data and shapefiles provided in 
Data\FigureData\Figure 3.S1 The Roads of 
Hispaniola\Materials\Shapefiles. The map was 
produced in QGIS by loading three layers: 
road_network.shp, national_borders.shp, and 
subnational_results_b_c.shp. 

 

For map a, the road network layer was styled using 
a Categorized symbology on the highway column, 
grouping OSM road classifications into three visual 
categories (motorway/trunk/primary, 
secondary/tertiary, and residential/unclassified) 
with decreasing line weights. 

For maps b and c, the subnational layer was styled 
using a Graduated symbology on the density and 
cpc columns respectively, with 10 classes using 
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https://download.geofabrik.de/central-america/haiti-and-domrep.html
https://download.geofabrik.de/central-america/haiti-and-domrep.html
https://datacatalog.worldbank.org/int/search/dataset/0038272/world-bank-official-boundaries
https://datacatalog.worldbank.org/int/search/dataset/0038272/world-bank-official-boundaries
https://data.worldpop.org/GIS/Population/Global_2015_2030/R2025A/2025/HTI/v1/100m/constrained/hti_pop_2025_CN_100m_R2025A_v1.tif


 

_2015_2030/R2025A/2025/HTI/v1/100m/constr
ained/hti_pop_2025_CN_100m_R2025A_v1.tif and 
https://data.worldpop.org/GIS/Population/Global
_2015_2030/R2025A/2025/DOM/v1/100m/const
rained/dom_pop_2025_CN_100m_R2025A_v1.tif, 
downloading directly from the link for Haiti and 
the Dominican Republic for 2025, and processed 
and visualized in QGIS. 
Road density and assets per capita data are the 
combination of the datasets above and the results 
of the analysis from results_v4.csv 
(https://datacatalog.worldbank.org/int/data/data
set/0067070/transport_infrastructure_stock_and_
value), processed and visualized in QGIS 

 

Natural Breaks (Jenks) and a Spectral (reversed) 
color ramp ranging from blue (lowest) to red 
(highest). 
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Figure 4.1. Electric Power System Architecture On-
grid and Off-grid.jpg 

" INFCE Files - INFCE 
Documents\ReproduciblePackage\Code\CodesToB
eShared\Figure 4.1. Electric Power System 
Architecture On-grid and Off-grid.pptx" 
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Chapter4_Figure2.png Python_Chap 1~6.ipynb  
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Chapter2_Figure2_Distribution_of_power_generati
on_capacity.png 

R_Chap 2,5.R  
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Chapter4_Figure4.png Python_Chap 1~6.ipynb  

Ma
p 
4.2
a 

Chapter4_Figure5_BRA.png Python_Chap 1~6.ipynb  
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Chapter4_Figure5_NGA.png Python_Chap 1~6.ipynb  
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Chapter4_Figure6_BRA.png Python_Chap 1~6.ipynb  
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Chapter4_Figure6_NGA.png Python_Chap 1~6.ipynb  
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Original file: Figure4_7a_Road.png 

Map created by map team after sharing the data 
and code 

Python_Chap 1~6.ipynb  
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Original file: Figure4_7b_Rail.png 

Map created by map team after sharing the data 
and code 

Python_Chap 1~6.ipynb  

https://data.worldpop.org/GIS/Population/Global_2015_2030/R2025A/2025/HTI/v1/100m/constrained/hti_pop_2025_CN_100m_R2025A_v1.tif
https://data.worldpop.org/GIS/Population/Global_2015_2030/R2025A/2025/HTI/v1/100m/constrained/hti_pop_2025_CN_100m_R2025A_v1.tif
https://data.worldpop.org/GIS/Population/Global_2015_2030/R2025A/2025/DOM/v1/100m/constrained/dom_pop_2025_CN_100m_R2025A_v1.tif
https://data.worldpop.org/GIS/Population/Global_2015_2030/R2025A/2025/DOM/v1/100m/constrained/dom_pop_2025_CN_100m_R2025A_v1.tif
https://data.worldpop.org/GIS/Population/Global_2015_2030/R2025A/2025/DOM/v1/100m/constrained/dom_pop_2025_CN_100m_R2025A_v1.tif
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Data and shapefiles provided in 
Data\Raw\FigureData\Figure 4.8 Subnational 
Distribution of Line Transport 
Infrastructure\Materials 

Road network data from OpenStreetMap were 
downloaded from GeoFabrik, 
https://download.geofabrik.de/asia/uzbekistan.ht
ml# and https://download.geofabrik.de/central-
america/haiti-and-domrep.html#, downloading 
directly from the link, converted to a shapefile, and 
visualized in QGIS. 
Population data were downloaded from WorldPop, 
https://data.worldpop.org/GIS/Population/Global
_2015_2030/R2025A/2025/UZB/v1/100m/constr
ained/uzb_pop_2025_CN_100m_R2025A_v1.tif and 
https://data.worldpop.org/GIS/Population/Global
_2015_2030/R2025A/2025/DOM/v1/100m/const
rained/dom_pop_2025_CN_100m_R2025A_v1.tif, 
downloading directly from the link for Uzbekistan 
and the Dominican Republic for 2025, and 
processed and visualized in QGIS. 
 
Administrative boundaries shapefile was obtained 
from the World Bank Cartography unit 
(https://datacatalog.worldbank.org/int/search/da
taset/0038272/world-bank-official-boundaries) 

The map was produced in QGIS using the following 
layers, all provided in the Materials folder: 

Boundary layers (loaded via Layer → Add Layer → 
Add Vector Layer): 

 

Background world boundaries: 
borders_background.shp 

Uzbekistan and Dominican Republic boundaries: 
borders_uzbekistan_domrep.shp — obtained from 
the World Bank Cartography unit 

 

Road network layers (loaded via Layer → Add 

Layer → Add Vector Layer): 

 

Uzbekistan roads: uzbekistan_roads.shp — sourced 
from OpenStreetMap via GeoFabrik 
(https://download.geofabrik.de/asia/uzbekistan.ht
ml) 

Dominican Republic roads: domrep_roads.shp — 
sourced from OpenStreetMap via GeoFabrik 
(https://download.geofabrik.de/central-
america/haiti-and-domrep.html) 

 

Population raster layers (loaded via Layer → Add 

Layer → Add Raster Layer): 

 

Uzbekistan population 2025: 
uzbekistan_population_2025.tif — sourced from 
WorldPop, 100m constrained estimate, 2025 
(https://data.worldpop.org/GIS/Population/Global
_2015_2030/R2025A/2025/UZB/v1/100m/constr
ained/uzb_pop_2025_CN_100m_R2025A_v1.tif) 

Dominican Republic population 2025: 
domrep_population_2025.tif — sourced from 
WorldPop, 100m constrained estimate, 2025 
(https://data.worldpop.org/GIS/Population/Global
_2015_2030/R2025A/2025/DOM/v1/100m/const
rained/dom_pop_2025_CN_100m_R2025A_v1.tif) 

 

Load all layers, then arrange them in the Layers 
panel in this order from top to bottom: country 
boundaries (borders_uzbekistan_domrep), road 
networks (both countries), population rasters 
(both countries), background world boundaries 
(borders_background) 
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Documents\ReproduciblePackage\Code\CodesToB
eShared\Figure4.9-DigitalArchitecture.pptx” 

Staf
f 
ela
bor
atio
n.  

Fig
ur
e 
4.5 

Same as Figure 2.3   

https://download.geofabrik.de/central-america/haiti-and-domrep.html
https://download.geofabrik.de/central-america/haiti-and-domrep.html
https://data.worldpop.org/GIS/Population/Global_2015_2030/R2025A/2025/UZB/v1/100m/constrained/uzb_pop_2025_CN_100m_R2025A_v1.tif
https://data.worldpop.org/GIS/Population/Global_2015_2030/R2025A/2025/UZB/v1/100m/constrained/uzb_pop_2025_CN_100m_R2025A_v1.tif
https://data.worldpop.org/GIS/Population/Global_2015_2030/R2025A/2025/UZB/v1/100m/constrained/uzb_pop_2025_CN_100m_R2025A_v1.tif
https://data.worldpop.org/GIS/Population/Global_2015_2030/R2025A/2025/DOM/v1/100m/constrained/dom_pop_2025_CN_100m_R2025A_v1.tif
https://data.worldpop.org/GIS/Population/Global_2015_2030/R2025A/2025/DOM/v1/100m/constrained/dom_pop_2025_CN_100m_R2025A_v1.tif
https://data.worldpop.org/GIS/Population/Global_2015_2030/R2025A/2025/DOM/v1/100m/constrained/dom_pop_2025_CN_100m_R2025A_v1.tif
https://datacatalog.worldbank.org/int/search/dataset/0038272/world-bank-official-boundaries
https://datacatalog.worldbank.org/int/search/dataset/0038272/world-bank-official-boundaries
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Figure_4_11_Numbers_of_IXPs_by_Region_and_Cap
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DigitalFigures.R Line 425 - 531  
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Figure_4_12_People_per_Fiber_km_and_Fixed_Dow
nload_Speed_by_Region.png 

DigitalFigures.R Line 537 - 664  
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Figure_4_13_Countries_by_Number_of_Submarine_
Cable_Landing Points.png 

DigitalFigures.R Line 327 - 418  

Ma
p 
4.6 

Raw data illustration, proprietary data 

Data stored in NDA\Digital\Map 4.6 Digital Infrastructure in Africa, 2025 

Data Source: Multiple sources using data from proprietary data. Telegeography 
(https://www2.telegeography.com/ 

); GlobalData (https://www.globaldata.com/); and publicly available data from TowerXchange 
(https://infraxchange.com/) and OpenCellId (https://www.opencellid.org/downloads.php) 

Access year: 2025 

Availability: Raw and cleaned data for the digital sector is compiled by the project team from public and 
proprietary data. Confidential. If needed, please contact Estefania Belen Vergara Cobos 
(evergaracobos@worldbank.org) for application details.  

 

The map was produced in QGIS using the following layers: 

Point layers (CSV, imported via Layer → Add Layer → Add Delimited Text Layer): 

 

Mobile cell towers: mobiles cells/ct_clipped_africa.csv 

Data centers: data centers/dc_clipped_africa.csv 

 

Cable layers (shapefiles, imported via Layer → Add Layer → Add Vector Layer): 

 

Submarine cables: TeleGeography, submarine cables/submarine_cables_clipped_africa.shp 

Terrestrial fiber optic cables: ITU, fiber optic cables/itu_transmission_lines_clipped_africa.shp 

 

Point layers (shapefiles/GeoJSON, imported via Layer → Add Layer → Add Vector Layer): 

 

Internet Exchange Points: ITU, ixp/itu_ixp_clipped_africa.shp / ixp/ITU_ixp.geojson 

 

Boundary and reference layers: 

 

Africa boundary: base/africa.shp 

Subnational boundaries: GSAP 2021, base/gsap_2021_clipped_africa.shp 

Population raster: base/pop_2025.tif (loaded via Layer → Add Layer → Add Raster Layer) 

 

All CSV layers were clipped to the Africa country boundary via Vector → Geoprocessing Tools → Clip. The 

OSM Standard basemap was added using Plugins → QuickMapServices → OSM Standard. 
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Raw data illustration, proprietary data 

Data stored in NDA\Digital\Map4_7 

Data Source: Multiple sources using data from proprietary data. Telegeography 
(https://www2.telegeography.com/ 

); GlobalData (https://www.globaldata.com/); and publicly available data from TowerXchange 
(https://infraxchange.com/) and OpenCellId (https://www.opencellid.org/downloads.php) 

Access year: 2025 

https://infraxchange.com/
mailto:evergaracobos@worldbank.org
https://infraxchange.com/


 

Availability: Raw and cleaned data for the digital sector is compiled by the project team from public and 
proprietary data. Confidential. If needed, please contact Estefania Belen Vergara Cobos 
(evergaracobos@worldbank.org) for application details.  

 

Each CSV file for the different infrastructure layers, except cables, was imported into QGIS using Layer → Add 
Layer → Add Delimited Text Layer. The layers were then clipped in QGIS using Vector → Clip, with the input data 
intersected with the corresponding country boundary. Maps were incorporated from QGIS itself by using Plugins 
→ Manage and Install Plugins → QuickMapServices → OSM Standard. 

The cable data were sourced from shapefiles. Submarine cable shapefiles were obtained from TeleGeography, 
and terrestrial cable shapefiles from the ITU.  
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Chapter5_Figure2a_Unit Cost of Selected 
Renewable Technologies(solar PV).png 
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Chapter5_Figure2b_Unit Cost of Selected 
Renewable Technologies (Wind Power).png 

R_Chap 2,5.R  

Fig
ur
e 
5.3 

Chapter5_Figure3_Installed Cost of Hydro Power 
2016-2023.png 
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Chapter5_Figure4_Unit Cost for Transmission 
Lines Million USD per km.png 
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Raw data illustration, proprietary data 

Data and code shared in NDA\Transport 

Data source: Global Data 

URL: https://www.globaldata.com/ 

Access year: May, 2025 

Availability: proprietary data, purchased data by Infrastructure Chief Economist Office 
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Raw data illustration, proprietary data 

Data and code shared in NDA\Transport 

Data source: Global Data 

URL: https://www.globaldata.com/ 

Access year: May, 2025 

Availability: proprietary data, purchased data by Infrastructure Chief Economist Office 
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Raw data illustration, proprietary data 

Data and code shared in NDA\Transport 

Data source: Global Data 

URL: https://www.globaldata.com/ 

Access year: May, 2025 

Availability: proprietary data, purchased data by Infrastructure Chief Economist Office 
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Data and shapefiles provided in 
Data\Raw\FigureData\Figure 5.8 Modelling 
Results Unit Cost of Roads \ 
regression_results_standardized.xlsx 

 

To obtain the results, using proprietary data from 
Global Data. Code is shared in NDA\Transport. 

Visualization is stored in the excel file  
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e 
5.9 

Data and shapefiles provided in 
Data\Raw\FigureData\ Figure 5.9 Modelling 
Results Unit Cost of Railways\ 
regression_results_standardized.xlsx 

 

To obtain the results, using proprietary data from 
Global Data. Code is shared in NDA\Transport. 

Visualization is stored in the excel file  
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Figure_5_10_Costs_of_Cell_Tower_by_Region.png DigitalFigures.R Line 670 - 747  
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Figure_5_11_Costs_of_Data_Centers_by_Region.png DigitalFigures.R Line 752 - 858     
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Figure_5_12_Costs_of_Terrestrial_FOC_by_Region.p
ng 

DigitalFigures.R Line 866 - 966  
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Figure_5_13_Costs_of_Terrestrial_FOC_by_Region.p
ng 

DigitalFigures.R Line 974 - 1093  
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“Chapter6_Figure1.csv” 

Original map: Chapter6_Figure1_temp.png 

Recreated map uses the csv output file. 
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Chapter6_Figure2a_Energy_temp.png Python_Chap 1~6.ipynb  
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Chapter6_Figure2b_EnergyPC_temp.png Python_Chap 1~6.ipynb  
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Chapter6_Figure3a_temp.png Python_Chap 1~6.ipynb  
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Chapter6_Figure3b_temp.png Python_Chap 1~6.ipynb  
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“Chapter6_Figure4.csv” 

Original map: Chapter6_Figure4_temp.png 

Recreated map uses the csv output file. 
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Chapter6_Figure5_Transport.png Python_Chap 1~6.ipynb  
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Chapter6_Figure6_TransportPC.png Python_Chap 1~6.ipynb  
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Data and shapefiles provided in 
Data\Raw\FigureData\ Figure 6.7 Subnational 
Distribution of Transport Nigeria\Materials 

 

Administrative boundaries shapefile was obtained 
from the World Bank Cartography unit 
(https://datacatalog.worldbank.org/int/search/da
taset/0038272/world-bank-official-boundaries) 
 

Road density, rail density, and transportation asset 
density data are the combination of the 
administrative boundaries and the results of 
results_v4.csv 
(https://datacatalog.worldbank.org/int/data/data
set/0067070/transport_infrastructure_stock_and_
value), processed and visualized in QGIS. 

 

 

Open QGIS and load the layers 

6.4a – Road Density 

 

Layer: road.shp | Value field: road_density 

Symbology: Graduated → Sequential color ramp 

(oranges/browns) → 5 classes, Quantile 

 

6.4b – Rail Density 

 

Layer: rail.shp | Value field: rail_density 

Symbology: Graduated → Sequential color ramp 

(blues/purples) → 5 classes, Quantile 

 

6.4c – Transportation Asset Density 

 

Layer: assetdensity.shp | Value field: 
variabledensity 

Symbology: Graduated → Sequential color ramp 

(greens/teals) → 5 classes, Natural Breaks (Jenks) 
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Same as Map S3.1.1 (c)   
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Figure_6_9_Spatial_Distribution_of_Digital_Capital_
Assets.png 

DigitalFigures.R 

Line 32-110 
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Figure_6_10_Digital_Capital_Assets_by_Region_and
_Component.png 
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Line 111-214 
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Figure_6_11_Per_Capita_Digital_Capital_Assets_by_
Region_and_Component.png 

DigitalFigures.R 

Line 221-329 
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Figure 6.12 (A) Subnational Distribution of Digital 
Capital Assets in Ecuador.png 
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Figure 6.12 (B) Subnational Distribution of Digital 
Capital Assets in Ecuador.png 

figure6.12_code.R  
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Figure7S4_impliedE_GDP_correlation.png Chapter7Appendix2_EnergyMeta.ipnyb  
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Figure7S5_impliedE_boxplot_Region_r.png Chapter7Appendix2_EnergyMeta.ipnyb  
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