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Data and Code Availability Statement
The paper uses public, non-confidential data we collected on agreements that
grant fishing access to African or Parties to the Nauru Agreement (PNA) waters.
The archive contains the data in the folder “data/”. The file is called 2. access.csv.

The paper uses public, non-confidential data from the World Bank on Consumer
Price Indices. The archive contains the data in the folder “data/”. The file is
called API_FP.CPI.TOTL_DS2_en_csv_v2_3358502.xlsx. We downloaded
the data on December 1, 2021 from https://data.worldbank.org/indicator/FP.CPI.TOTL.

The paper uses public, non-confidential data from the Pacific Islands Forum
Fisheries Agency on PNA countries’ access fee revenue. The archive contains
the data in the folder “data/”. The file is called Compendium of Economic and
Development Statistics 2020.xlsx. We downloaded the data on September 23,
2021 from https://www.ffa.int/node/2596.

The paper uses data produced by the authors on ex-vessel prices of tuna in the
year 2019. The archive contains the data in the folder “data/”. The file is called
exvessel_tuna_2019.csv. These data were produced by applying the method of
Melnychuck et al. (2017; ICES Journal of Marine Science) to updated data from
the Food and Agriculture Organization.

The paper uses public, non-confidential data on fishing vessels from Global
Fishing Watch. The archive contains the data in the folder “data/”. The file
is called fishing-vessels-v2.csv. We downloaded the data on April 7, 2022 from
https://globalfishingwatch.org/datasets-and-code/.

The paper uses public, non-confidential fishing activity data from Global
Fishing Watch. The archive contains the data in the folder “data/mmsi-
daily-csvs-10-v2”. We downloaded the data on April 7, 2022 from
https://globalfishingwatch.org/datasets-and-code/.

The paper uses data produced by the authors on the growth rates of fish stocks
from Costello et al. (2016; PNAS). The archive contains the data in the folder
“data/”. The file is called Unlumped_ProjectionData.csv.

The paper uses public, non-confidential data from the Pacific Islands Forum
Fisheries Agency on catch in PNA countries’ waters. The archive contains
the data in the folder “data/”. The file is called Value of WCPFC-CA tuna
fisheries 2022_0.xlsx. We downloaded the data on August 9, 2022 from
https://www.ffa.int/node/2721.

The paper uses public, non-confidential data from the Sea Around US on
catch in African and PNA countries’ waters. The archive contains the
data in the folder “data/SAU/”. We downloaded the data on African
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and PNA countries on May 9, 2022 and August 9, 2022, respectively, from
https://www.seaaroundus.org/data/#/eez. Replicators who wish to re-download
the raw data must manually click on each country, and then click “Download
Data” for that country.

The paper uses public, non-confidential boundary data of countries’ Ex-
clusive Economic Zones from the Flanders Marine Institute (Flanders
Marine Institute, 2019). The archive contains the data in the folder
“data/World_EEZ_v11_20191118”. We downloaded the data on September 23,
2021 from https://www.marineregions.org/downloads.php.

Computational Requirements
Software and Hardware Requirements

-Software: R. We used Version 4.1.0, but other versions should work too, especially
those >= 4.1.0.

You may also need to install Rtools 4.0: https://cran.r-project.org/bin/windows/Rtools/rtools40.html

-Packages: There are many of them. They are all recorded in renv.lock file.
When you run Scripts/RUN THIS FIRST.R, the renv package will automatically
install all of them.

-OS: We used Windows 10. Other versions of Windows, as well as Mac and
Linux, should work too.

-CPU: We have Intel(R) Core(TM) i7-8565U CPU @ 1.80GHz 1.99 GHz

-Installed RAM: 8 GB

Description of programs/code
-RUN THIS FIRST.R installs all required R packages

-files in scripts/make_data folder make the object(s) described in the title
of the script. For example, calculate_avg_eu_fee_ton.R creates the object
avg_eu_fee_ton.Rdata (the average access fee paid by the European Union).

-policy_function_and_simulation_african_continent.R performs the main anal-
ysis of the paper and outputs the results.

-policy_function_and_simulation_african_regional.R considers the case of re-
gional African selling coalitions (rather than a continent-level coalition) and
outputs the results.

-policy_function_and_simulation_pna.R applies the model to the case of the
Parties to the Nauru Agreement (PNA) countries’ market and outputs the
results.

-percent_nonaccess_domestic.R calculates the % of non-access catch that is
domestic, as opposed to unauthorized foreign.
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-files in scripts/robustness_checks perform the robustness check indicated by the
file name. For example, policy_function_and_simulation_african_bbmsy_point4.R
re-runs the model when selling countries’ status quo biomass relative to biomass
at maximum sustainable yield is 0.4 (instead of the main specification’s value of
0.8).

-files in scripts/make_figures create the figure(s) listed in the script name. For
example, plot_figure2_S17_S18 creates Figures 2, S17, and S18.

-files in scripts/make_tables create the table(s) listed in the script name. For
example, make_table1.R creates Table 1

Downloading and opening the replication files

Download the four parts of the reproducibility package first and then unzip
part 1 (RR_AFR_2023_17-v01.zip). This file contains the folder structure
in which you should unzip the remaining parts of the reproducibility pack-
age. Then unzip the contents of the three remaining parts in the folder
data/mmsi-daily-csvs-10-v2 to replicate the full folder and file structure.

After that, open RStudio, click File -> Open Project, find access.Rproj
among the files on your computer, and click Open. If you are cloning
the repository from Github (https://github.com/englander/access), open
RStudio, click File -> New Project -> Version Control -> Git, paste
“https://github.com/englander/access.git”, and click Create Project.

Installing specific package versions

First, run Scripts/RUN THIS FIRST.R. That script will install all R packages you
need. It installs the same package versions we used to facilitate reproducibility.

Data preparation

Run the scripts in scripts/make_data folder first. calculate_gt_africa.R takes
about 45 hours to run, but this time can be reduced by increasing the number of
cores used on line 152 (choose a number larger than 4, depending on the number of
cores of your machine, in plan(multisession, workers = 4)). calculate_gt_pna.R
takes about 1.5 hours to run, make_pairwise_buyer_african_seller_hours_df.R
takes about 18 hours to run, and make_pairwise_buyer_pna_seller_hours_df.R
takes about 7 hours to run (these run times can also be reduced by increasing
the number of cores used in plan(multisession, workers = 4)). The remaining
scripts take about 10 minutes to run in total.

Analysis

Next run the three policy_function_and_simulation_* scripts. These scripts
take 1 hour to run in total.
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Then run the policy_function_and_simulation_* scripts in scripts/robustness_checks
folder. These scripts take 2 hours to run in total.

Running scripts in scripts/make_figures folder will reproduce figures in the
paper, and running scripts in scripts/make_tables will reproduce tables in the
paper. Scripts in either of these folders are fast to run, requiring no more than a
few minutes each.

Output-Exhibit Correspondence

For figures whose output names are not Figure 1 etc.

• Fig 2a-d = access_harvest_percent_diff.png, pi_percent_diff.png,
total_harvest_percent_diff.png, and biomass_percent_diff.png, respec-
tively.

• Fig S3a-d = access_harvest_sq_twice_baseline_threshold.png, ac-
cess_harvest_percent_diff_twice_baseline_threshold.png, pi_sq_twice_baseline_threshold.png,
pi_percent_diff_twice_baseline_threshold.png, respectively.

• Fig S4a-d = total_harvest_sq_twice_baseline_threshold.png, to-
tal_harvest_percent_diff_twice_baseline_threshold.png, biomass_tons_sq_twice_baseline_threshold.png,
biomass_percent_diff_twice_baseline_threshold.png, respectively.

• Fig S5a-d = access_harvest_sq_bbmsy_point6.png, access_harvest_percent_diff_bbmsy_point6.png,
pi_sq_bbmsy_point6.png, pi_percent_diff_bbmsy_point6.png, respec-
tively.

• Fig S6a-d = total_harvest_sq_bbmsy_point6.png, total_harvest_percent_diff_bbmsy_point6.png,
biomass_tons_sq_bbmsy_point6.png, biomass_percent_diff_bbmsy_point6.png,
respectively.

• Fig S7a-d = access_harvest_sq_bbmsy_point4.png, access_harvest_percent_diff_bbmsy_point4.png,
pi_sq_bbmsy_point4.png, pi_percent_diff_bbmsy_point4.png, respec-
tively.

• Fig S8a-d = total_harvest_sq_bbmsy_point4.png, total_harvest_percent_diff_bbmsy_point4.png,
biomass_tons_sq_bbmsy_point4.png, biomass_percent_diff_bbmsy_point4.png,
respectively.

• Fig S9a-d = access_harvest_sq_eta_point5.png, access_harvest_percent_diff_eta_point5.png,
pi_sq_eta_point5.png, pi_percent_diff_eta_point5.png, respectively.

• Fig S10a-d = total_harvest_sq_eta_point5.png, total_harvest_percent_diff_eta_point5.png,
biomass_tons_sq_eta_point5.png, biomass_percent_diff_eta_point5.png,
respectively.

• Fig S11a-d = access_harvest_sq_eta_1point5.png, access_harvest_percent_diff_eta_1point5.png,
pi_sq_eta_1point5.png, pi_percent_diff_eta_1point5.png, respectively.
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• Fig S12a-d = total_harvest_sq_eta_1point5.png, total_harvest_percent_diff_eta_1point5.png,
biomass_tons_sq_eta_1point5.png, biomass_percent_diff_eta_1point5.png,
respectively.

• Fig S13a-d = access_harvest_sq_epsilon_1point5.png, access_harvest_percent_diff_epsilon_1point5.png,
pi_sq_epsilon_1point5.png, pi_percent_diff_epsilon_1point5.png, re-
spectively.

• Fig S14a-d = total_harvest_sq_epsilon_1point5.png, total_harvest_percent_diff_epsilon_1point5.png,
biomass_tons_sq_epsilon_1point5.png, biomass_percent_diff_epsilon_1point5.png,
respectively.

• Fig S15a-d = access_harvest_sq_epsilon_2point5.png, access_harvest_percent_diff_epsilon_2point5.png,
pi_sq_epsilon_2point5.png, pi_percent_diff_epsilon_2point5.png, re-
spectively.

• Fig S16a-d = total_harvest_sq_epsilon_2point5.png, total_harvest_percent_diff_epsilon_2point5.png,
biomass_tons_sq_epsilon_2point5.png, biomass_percent_diff_epsilon_2point5.png,
respectively.

• Fig S17a-d = access_harvest_sq.png, pi_sq.png, total_harvest_sq.png,
biomass_tons_sq.png, respectively.

• Fig S18a-b = non_access_harvest_sq.png, non_access_harvest_percent_diff.png

• Fig S20a-d = access_harvest_sq_regional.png, access_harvest_percent_diff_regional.png,
pi_sq_regional.png, pi_percent_diff_regional.png, respectively.

• Fig S21a-d = total_harvest_sq_regional.png, total_harvest_percent_diff_regional.png,
biomass_tons_sq_regional.png, biomass_percent_diff_regional.png,
respectively.

• Fig S22a-d = pna_access_harvest_sq_thousands.png, pna_access_harvest_percent_diff.png,
pna_pi_sq_millions.png, pna_pi_percent_diff.png, respectively.

• Fig S23a-d = pna_total_harvest_sq_thousands.png, pna_total_harvest_percent_diff.png,
pna_biomass_tons_sq_millions.png, pna_biomass_percent_diff.png,
respectively.

• Fig S24a-d = pna_access_harvest_sq_thousands_half_access_catch.png,
pna_access_harvest_percent_diff_half_access_catch.png, pna_pi_sq_millions_half_access_catch.png,
pna_pi_percent_diff_half_access_catch.png, respectively.

• Fig S25a-d = pna_total_harvest_sq_thousands_half_access_catch.png,
pna_total_harvest_percent_diff_half_access_catch.png, pna_biomass_tons_sq_millions_half_access_catch.png,
pna_biomass_percent_diff_half_access_catch.png, respectively. Fig
S26a-d = pna_access_harvest_sq_thousandsbbmsy_1point3.png,
pna_access_harvest_percent_diffbbmsy_1point3.png, pna_pi_sq_millionsbbmsy_1point3.png,
pna_pi_percent_diffbbmsy_1point3.png, respectively. Fig S27a-d =
pna_total_harvest_sq_thousandsbbmsy_1point3.png, pna_total_harvest_percent_diffbbmsy_1point3.png,
pna_biomass_tons_sq_millionsbbmsy_1point3.png, pna_biomass_percent_diffbbmsy_1point3.png,
respectively.
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